CUPS < 1.7.2 is_path_absolute Function XSS

medium Nessus Plugin ID 73734
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote print service is affected by a cross-site scripting vulnerability.


According to its banner, the version of CUPS installed on the remote host is prior to version 1.7.2. It is, therefore, affected by a cross-site scripting vulnerability.

A flaw exists with the is_path_absolute function within the scheduler/client.cscript. This could allow a context-dependent attacker, with a specially crafted request, to execute arbitrary script code within the browser and server trust relationship.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to CUPS version 1.7.2 or later, or apply the vendor patch.

See Also

Plugin Details

Severity: Medium

ID: 73734

File Name: cups_1_7_2.nasl

Version: 1.7

Type: remote

Family: Misc.

Published: 4/28/2014

Updated: 11/15/2018

Dependencies: http_version.nasl, cups_1_3_5.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/10/2014

Vulnerability Publication Date: 1/30/2014

Reference Information

CVE: CVE-2014-2856

BID: 66788

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990