CUPS < 1.7.2 is_path_absolute Function XSS

Medium Nessus Plugin ID 73734


The remote print service is affected by a cross-site scripting vulnerability.


According to its banner, the version of CUPS installed on the remote host is prior to version 1.7.2. It is, therefore, affected by a cross-site scripting vulnerability.

A flaw exists with the is_path_absolute function within the scheduler/client.cscript. This could allow a context-dependent attacker, with a specially crafted request, to execute arbitrary script code within the browser and server trust relationship.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to CUPS version 1.7.2 or later, or apply the vendor patch.

See Also

Plugin Details

Severity: Medium

ID: 73734

File Name: cups_1_7_2.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2014/04/28

Modified: 2015/02/02

Dependencies: 10107, 29727

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/10

Vulnerability Publication Date: 2014/01/30

Reference Information

CVE: CVE-2014-2856

BID: 66788

OSVDB: 105715

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990