VMware Workstation 10.x < 10.0.2 OpenSSL Library Multiple Vulnerabilities (VMSA-2014-0004) (Heartbleed)

High Nessus Plugin ID 73674


The remote host has a virtualization application that is affected by multiple vulnerabilities.


The version of VMware Workstation installed on the remote host is version 10.x prior to 10.0.2. It is, therefore, reportedly affected by the following vulnerabilities in the OpenSSL library :

- An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that could allow nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076)

- An out-of-bounds read error, known as the 'Heartbleed Bug', exists related to handling TLS heartbeat extensions that could allow an attacker to obtain sensitive information such as primary key material, secondary key material and other protected content.


Upgrade to VMware Workstation 10.0.2 or later.

See Also







Plugin Details

Severity: High

ID: 73674

File Name: vmware_workstation_multiple_vmsa_2014_0004.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2014/04/21

Modified: 2017/06/12

Dependencies: 26201

Risk Information

Risk Factor: High


Base Score: 9.4

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: VMware/Workstation/Version, VMware/Workstation/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/17

Vulnerability Publication Date: 2014/02/24

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0076, CVE-2014-0160

BID: 66363, 66690

OSVDB: 104810, 105465

CERT: 720951

EDB-ID: 32745, 32764, 32791, 32998

VMSA: 2014-0004