Splunk 6.x < 6.0.3 Multiple OpenSSL Vulnerabilities (Heartbleed)

medium Nessus Plugin ID 73575
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains an application that is affected by multiple OpenSSL-related vulnerabilities.

Description

According to its version number, the Splunk Web hosted on the remote web server is 6.x prior to 6.0.3. It is, therefore, affected by multiple OpenSSL-related vulnerabilities :

- A flaw exists with the OpenSSL version being used by Splunk with the 'ssl3_take_mac' in 'ssl/s3_both.c'. This allows a remote attacker to cause a denial of service with a specially crafted request. (CVE-2013-4353)

- An out-of-bounds read error, known as Heartbleed, exists in the TLS/DTLS implementation due to improper handling of TLS heartbeat extension packets. A remote attacker, using crafted packets, can trigger a buffer over-read, resulting in the disclosure of up to 64KB of process memory, which contains sensitive information such as primary key material, secondary key material, and other protected content. (CVE-2014-0160)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Splunk 6.0.3 or later.

See Also

https://www.splunk.com/view/SP-CAAAMB3

http://docs.splunk.com/Documentation/Splunk/6.0.3/ReleaseNotes/6.0.3

http://www.heartbleed.com

http://eprint.iacr.org/2014/140

http://www.openssl.org/news/vulnerabilities.html#2014-0160

https://www.openssl.org/news/secadv/20140407.txt

Plugin Details

Severity: Medium

ID: 73575

File Name: splunk_603.nasl

Version: 1.16

Type: remote

Family: Web Servers

Published: 4/16/2014

Updated: 11/26/2019

Dependencies: splunkd_detect.nasl, splunk_web_detect.nasl

Risk Information

CVSS Score Source: CVE-2014-0160

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/10/2014

Vulnerability Publication Date: 2/24/2014

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-4353, CVE-2014-0160

BID: 64691, 66690

CERT: 720951

EDB-ID: 32745, 32764, 32791, 32998