Fortinet FortiWeb 4.x / 5.x < 5.0.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 73528

Synopsis

The remote host is affected by multiple vulnerabilities.

Description

The remote host is running FortiWeb 4.x / 5.x prior to 5.0.3. It is, therefore, affected by multiple vulnerabilities :

- FortiWeb is affected by a cross-site scripting vulnerability due to a failure to sanitize user-supplied input. (CVE-2014-1955)

- FortiWeb is affected by an unspecified HTTP header injection vulnerability. (CVE-2014-1956)

- FortiWeb is affected by an unspecified privilege escalation vulnerability. (CVE-2014-1957)

Solution

Upgrade to Fortinet FortiWeb 5.0.3 or later.

See Also

http://www.fortiguard.com/advisory/FG-IR-13-009

Plugin Details

Severity: Medium

ID: 73528

File Name: fortiweb_FG-IR-13-009.nasl

Version: $Revision: 1.4 $

Type: local

Family: CGI abuses

Published: 2014/04/15

Modified: 2015/04/23

Dependencies: 73522

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortiweb

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/10/11

Vulnerability Publication Date: 2014/02/13

Reference Information

CVE: CVE-2014-1955, CVE-2014-1956, CVE-2014-1957

BID: 65660

OSVDB: 103449, 103450, 103451

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990