stunnel < 5.01 OpenSSL Heartbeat Information Disclosure (Heartbleed)

High Nessus Plugin ID 73500

Synopsis

The remote Windows host contains a program that is affected by an information disclosure vulnerability.

Description

The version of stunnel installed on the remote host is prior to version 5.01. It is, therefore, affected by an information disclosure vulnerability in the bundled OpenSSL DLLs. A remote attacker can read the contents of up to 64KB of server memory, potentially exposing passwords, private keys, and other sensitive data.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to stunnel version 5.01 or later.

See Also

https://www.stunnel.org/?page=sdf_ChangeLog

http://www.nessus.org/u?52a6ced6

http://www.heartbleed.com

https://eprint.iacr.org/2014/140

https://www.openssl.org/news/vulnerabilities.html#2014-0160

https://www.openssl.org/news/secadv/20140407.txt

Plugin Details

Severity: High

ID: 73500

File Name: stunnel_5_01.nasl

Version: 1.14

Type: local

Agent: windows

Family: Windows

Published: 2014/04/14

Updated: 2018/11/15

Dependencies: 65689

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.4

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:stunnel:stunnel

Required KB Items: installed_sw/stunnel

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/08

Vulnerability Publication Date: 2014/02/24

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0160

BID: 66690

CERT: 720951

EDB-ID: 32745, 32764, 32791, 32998