Debian DSA-2899-1 : openafs - security update

medium Nessus Plugin ID 73441

Synopsis

The remote Debian host is missing a security-related update.

Description

Michael Meffie discovered that in OpenAFS, a distributed filesystem, an attacker with the ability to connect to an OpenAFS fileserver can trigger a buffer overflow, crashing the fileserver, and potentially permitting the execution of arbitrary code.

In addition, this update addresses a minor denial of service issue:
the listener thread of the server will hang for about one second when receiving an invalid packet, giving the opportunity to slow down the server to an unusable state by sending such packets.

Solution

Upgrade the openafs packages.

For the oldstable distribution (squeeze), this problem has been fixed in version 1.4.12.1+dfsg-4+squeeze3.

For the stable distribution (wheezy), this problem has been fixed in version 1.6.1-3+deb7u2.

See Also

https://packages.debian.org/source/squeeze/openafs

https://packages.debian.org/source/wheezy/openafs

https://www.debian.org/security/2014/dsa-2899

Plugin Details

Severity: Medium

ID: 73441

File Name: debian_DSA-2899.nasl

Version: 1.11

Type: local

Agent: unix

Published: 4/10/2014

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openafs, cpe:/o:debian:debian_linux:6.0, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/9/2014

Reference Information

CVE: CVE-2014-0159, CVE-2014-2852

BID: 66776

DSA: 2899