PHP 5.5.x < 5.5.11 awk Magic Parsing BEGIN DoS

medium Nessus Plugin ID 73411


The remote web server uses a version of PHP that is potentially affected by a denial of service vulnerability.


According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.11. It is, therefore, potentially affected by a denial of service vulnerability.

A flaw exists in the awk script detector within magic/Magdir/commands where multiple wildcards with unlimited repetitions are used. This could allow a context dependent attacker to cause a denial of service with a specially crafted ASCII file.

Note that this plugin has not attempted to exploit this issue, but has instead relied only on PHP's self-reported version number.


Upgrade to PHP version 5.5.11 or later.

See Also

Plugin Details

Severity: Medium

ID: 73411

File Name: php_5_5_11.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 4/8/2014

Updated: 4/7/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2013-7345

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 4/3/2014

Vulnerability Publication Date: 12/31/2011

Reference Information

CVE: CVE-2013-7345

BID: 66406