OpenSSL 1.0.0 < 1.0.0m Multiple Vulnerabilities

High Nessus Plugin ID 73403

Synopsis

The remote service is affected by multiple vulnerabilities.

Description

According to its banner, the remote web server uses a version of OpenSSL 1.0.0 prior to 1.0.0m. The OpenSSL library is, therefore, reportedly affected by the following vulnerabilities :

- An error exists in the function 'ssl3_read_bytes' that could allow data to be injected into other sessions or allow denial of service attacks. Note this issue is only exploitable if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2010-5298)

- An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that could allow nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076)

- A buffer overflow error exists related to invalid DTLS fragment handling that could lead to execution of arbitrary code. Note this issue only affects OpenSSL when used as a DTLS client or server. (CVE-2014-0195)

- An error exists in the function 'do_ssl3_write' that could allow a NULL pointer to be dereferenced leading to denial of service attacks. Note this issue is exploitable only if 'SSL_MODE_RELEASE_BUFFERS' is enabled. (CVE-2014-0198)

- An error exists related to DTLS handshake handling that could lead to denial of service attacks. Note this issue only affects OpenSSL when used as a DTLS client.
(CVE-2014-0221)

- An unspecified error exists that could allow an attacker to cause usage of weak keying material leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH ciphersuites that could allow denial of service attacks. Note this issue only affects OpenSSL TLS clients. (CVE-2014-3470)

- An integer underflow condition exists in the EVP_DecodeUpdate() function due to improper validation of base64 encoded input when decoding. This allows a remote attacker, using maliciously crafted base64 data, to cause a segmentation fault or memory corruption, resulting in a denial of service or possibly the execution of arbitrary code. (CVE-2015-0292)

Solution

Upgrade to OpenSSL 1.0.0m or later.

See Also

https://www.openssl.org/news/secadv/20140605.txt

https://www.openssl.org/news/secadv/20150319.txt

http://eprint.iacr.org/2014/140

http://www.openssl.org/news/vulnerabilities.html#CVE-2010-5298

http://www.openssl.org/news/vulnerabilities.html#2014-0076

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0198

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0221

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0224

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-3470

http://ccsinjection.lepidum.co.jp/

https://www.imperialviolet.org/2014/06/05/earlyccs.html

Plugin Details

Severity: High

ID: 73403

File Name: openssl_1_0_0m.nasl

Version: $Revision: 1.19 $

Type: remote

Family: Web Servers

Published: 2014/04/08

Modified: 2016/05/12

Dependencies: 57323

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/07

Vulnerability Publication Date: 2014/02/24

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-5298, CVE-2014-0076, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-3470, CVE-2015-0292

BID: 66363, 66801, 67193, 67898, 67899, 67900, 67901, 73228

OSVDB: 104810, 105763, 106531, 107729, 107730, 107731, 107732, 119743

CERT: 978508