PHP 5.4.x < 5.4.27 awk Magic Parsing BEGIN DoS

medium Nessus Plugin ID 73338

Synopsis

The remote web server uses a version of PHP that is potentially affected by a denial of service vulnerability.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.27. It is, therefore, potentially affected by a denial of service vulnerability.

A flaw exists in the awk script detector within magic/Magdir/commands where multiple wildcards with unlimited repetitions are used. This could allow a context dependent attacker to cause a denial of service with a specially crafted ASCII file.

Note that this plugin has not attempted to exploit this issue, but instead relied only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.27 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.27

Plugin Details

Severity: Medium

ID: 73338

File Name: php_5_4_27.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 4/4/2014

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2013-7345

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 4/3/2014

Vulnerability Publication Date: 12/31/2011

Reference Information

CVE: CVE-2013-7345

BID: 66406