Debian DSA-2886-1 : libxalan2-java - security update

high Nessus Plugin ID 73216
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Nicolas Gregoire discovered several vulnerabilities in libxalan2-java, a Java library for XSLT processing. Crafted XSLT programs could access system properties or load arbitrary classes, resulting in information disclosure and, potentially, arbitrary code execution.

Solution

Upgrade the libxalan2-java packages.

For the oldstable distribution (squeeze), this problem has been fixed in version 2.7.1-5+deb6u1.

For the stable distribution (wheezy), this problem has been fixed in version 2.7.1-7+deb7u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=742577

https://packages.debian.org/source/wheezy/libxalan2-java

https://www.debian.org/security/2014/dsa-2886

Plugin Details

Severity: High

ID: 73216

File Name: debian_DSA-2886.nasl

Version: 1.10

Type: local

Agent: unix

Published: 3/27/2014

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxalan2-java, cpe:/o:debian:debian_linux:6.0, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 3/26/2014

Reference Information

CVE: CVE-2014-0107

BID: 66397

DSA: 2886