GLSA-201403-05 : GNU Emacs: Multiple vulnerabilities

High Nessus Plugin ID 73127


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201403-05 (GNU Emacs: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in GNU Emacs:
When ‘global-ede-mode’ is enabled, EDE in Emacs automatically loads a Project.ede file from the project directory (CVE-2012-0035).
When ‘enable-local-variables’’ is set to ‘:safe’, Emacs automatically processes eval forms (CVE-2012-3479).
Impact :

A remote attacker could entice a user to open a specially crafted file, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All GNU Emacs 24.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-editors/emacs-24.1-r1' All GNU Emacs 23.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-editors/emacs-23.4-r4'

See Also

Plugin Details

Severity: High

ID: 73127

File Name: gentoo_GLSA-201403-05.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/03/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emacs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/03/20

Reference Information

CVE: CVE-2012-0035, CVE-2012-3479

BID: 51354, 54969

OSVDB: 78244, 84691

GLSA: 201403-05