OpenSSH < 6.6 Multiple Vulnerabilities

High Nessus Plugin ID 73079


The SSH server on the remote host is affected by multiple vulnerabilities.


According to its banner, the version of OpenSSH running on the remote host is prior to 6.6. It is, therefore, affected by the following vulnerabilities :

- A flaw exists due to a failure to initialize certain data structures when is modified to enable the J-PAKE protocol. An unauthenticated, remote attacker can exploit this to corrupt memory, resulting in a denial of service condition and potentially the execution of arbitrary code. (CVE-2014-1692)

- An error exists related to the 'AcceptEnv' configuration setting in sshd_config due to improper processing of wildcard characters. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to bypass intended environment restrictions.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to OpenSSH version 6.6 or later.

See Also

Plugin Details

Severity: High

ID: 73079

File Name: openssh_66.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Misc.

Published: 2014/03/18

Modified: 2016/06/15

Dependencies: 10267

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/03/15

Vulnerability Publication Date: 2014/03/15

Reference Information

CVE: CVE-2014-1692, CVE-2014-2532

BID: 65230, 66355

OSVDB: 102611, 104578