Mandriva Linux Security Advisory : mediawiki (MDVSA-2014:057)

High Nessus Plugin ID 73004


The remote Mandriva Linux host is missing one or more security updates.


Updated mediawiki packages fix multiple vulnerabilities :

MediaWiki user Michael M reported that the fix for CVE-2013-4568 allowed insertion of escaped CSS values which could pass the CSS validation checks, resulting in XSS (CVE-2013-6451).

Chris from RationalWiki reported that SVG files could be uploaded that include external stylesheets, which could lead to XSS when an XSL was used to include JavaScript (CVE-2013-6452).

During internal review, it was discovered that MediaWiki's SVG sanitization could be bypassed when the XML was considered invalid (CVE-2013-6453).

During internal review, it was discovered that MediaWiki displayed some information about deleted pages in the log API, enhanced RecentChanges, and user watchlists (CVE-2013-6472).

Netanel Rubin from Check Point discovered a remote code execution vulnerability in MediaWiki's thumbnail generation for DjVu files.
Internal review also discovered similar logic in the PdfHandler extension, which could be exploited in a similar way (CVE-2014-1610).

MediaWiki before 1.22.3 does not block unsafe namespaces, such as a W3C XHTML namespace, in uploaded SVG files. Some client software may use these namespaces in a way that results in XSS. This was fixed by disallowing uploading SVG files using non-whitelisted namespaces (CVE-2014-2242).

MediaWiki before 1.22.3 performs token comparison that may be vulnerable to timing attacks. This was fixed by making token comparison use constant time (CVE-2014-2243).

MediaWiki before 1.22.3 could allow an attacker to perform XSS attacks, due to flaw with link handling in api.php. This was fixed such that it won't find links in the middle of api.php links (CVE-2014-2244).

MediaWiki has been updated to version 1.22.3, which fixes these issues, as well as several others.

Also, the mediawiki-ldapauthentication and mediawiki-math extensions have been updated to newer versions that are compatible with MediaWiki 1.22.

Additionally, the mediawiki-graphviz extension has been obsoleted, due to the fact that it is unmaintained upstream and is vulnerable to cross-site scripting attacks.

Note: if you were using the instances feature in these packages to support multiple wiki instances, this feature has now been removed.
You will need to maintain separate wiki instances manually.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 73004

File Name: mandriva_MDVSA-2014-057.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2014/03/14

Modified: 2014/10/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mediawiki, p-cpe:/a:mandriva:linux:mediawiki-ldapauthentication, p-cpe:/a:mandriva:linux:mediawiki-mysql, p-cpe:/a:mandriva:linux:mediawiki-pgsql, p-cpe:/a:mandriva:linux:mediawiki-sqlite, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/03/13

Exploitable With

Core Impact

Metasploit (MediaWiki Thumb.php Remote Command Execution)

Elliot (MediaWiki thumb.php page Parameter Remote Shell Command Injection)

Reference Information

CVE: CVE-2013-6451, CVE-2013-6452, CVE-2013-6453, CVE-2013-6472, CVE-2014-1610, CVE-2014-2242, CVE-2014-2243, CVE-2014-2244

BID: 65003, 65223, 65883, 65906, 65910

MDVSA: 2014:057