GLSA-201403-02 : LibYAML: Arbitrary code execution

Medium Nessus Plugin ID 72894


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201403-02 (LibYAML: Arbitrary code execution)

A heap-based buffer overflow flaw was found in the way libyaml parsed YAML tags.
Impact :

A remote attacker could provide a specially crafted YAML document which when parsed by LibYAML, would cause the application to crash or, potentially, execute arbitrary code with the privileges the user who is running the application.
Workaround :

There is no known workaround at this time.


All LibYAML users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/libyaml-0.1.5'

See Also

Plugin Details

Severity: Medium

ID: 72894

File Name: gentoo_GLSA-201403-02.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2014/03/10

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libyaml, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/03/08

Reference Information

CVE: CVE-2013-6393

BID: 65258

OSVDB: 102716

GLSA: 201403-02