PHP 5.4.x < 5.4.26 Multiple Vulnerabilities

Medium Nessus Plugin ID 72881

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.26. It is, therefore, potentially affected by the following vulnerabilities :

- An error exists related to the Fileinfo extension and the bundled libmagic library that could allow denial of service attacks. (CVE-2014-1943)

- An error exists related to the Fileinfo extension and the process of analyzing Portable Executable (PE) format files that could allow denial of service attacks or possibly arbitrary code execution. (CVE-2014-2270)

Note that this plugin does not attempt to exploit the vulnerabilities, but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.26 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.26

Plugin Details

Severity: Medium

ID: 72881

File Name: php_5_4_26.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2014/03/07

Updated: 2019/11/26

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-1943

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/03/06

Vulnerability Publication Date: 2013/12/20

Reference Information

CVE: CVE-2014-1943, CVE-2014-2270

BID: 65596, 66002