Palo Alto Networks PAN-OS 5.x < 5.0.9 Multiple Vulnerabilities

Medium Nessus Plugin ID 72829


The remote host is affected by multiple vulnerabilities.


The remote host is running a version of Palo Alto Networks PAN-OS 5.x prior to 5.0.9. It is, therefore, affected by multiple vulnerabilities :

- A security bypass vulnerability exists due to a failure to properly enforce RADIUS users' permissions. An authenticated attacker can exploit this to modify shared objects. (Ref# 55287)

- A cross-site request forgery vulnerability exists due to a failure to properly validate HTTP requests to certain file upload forms, including 'import.certificate.php'.

- Multiple HTML injection vulnerabilities exist due to a failure to sanitize user-supplied input to the 'Name', 'Subject', and 'Issuer' fields in imported certificates.
An attacker can exploit this to inject arbitrary HTML into the device's web interface.
(Ref# 57343)


Upgrade to PAN-OS version 5.0.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 72829

File Name: palo_alto_pan-os_5_0_9.nasl

Version: 1.9

Type: combined

Published: 2014/03/05

Modified: 2018/08/08

Dependencies: 72816

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/11/17

Vulnerability Publication Date: 2013/11/21

Reference Information

BID: 63984, 64602

EDB-ID: 29861

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990