Palo Alto Networks PAN-OS < 3.1.10 / 4.x < 4.0.4 Multiple Command Injections

Critical Nessus Plugin ID 72819


The remote host is affected by multiple command injection vulnerabilities.


The remote host is running a version of Palo Alto Networks PAN-OS prior to 3.1.10 / 4.0.4. It is, therefore, affected by multiple command injection vulnerabilities :

- A vulnerability exists that allows an unauthenticated user to inject commands as root on the device.
(CVE-2012-6593 / PAN-SA-2012-0004)

- A vulnerability exists that allows an authenticated user to inject arbitrary shell commands via the CLI.
(CVE-2012-6602 / PAN-SA-2012-0013)


Upgrade to PAN-OS version 3.1.10 / 4.0.4 or later.

See Also

Plugin Details

Severity: Critical

ID: 72819

File Name: palo_alto_PAN-SA-2012-0004_0013.nasl

Version: $Revision: 1.6 $

Type: combined

Published: 2014/03/05

Modified: 2016/05/16

Dependencies: 72816

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/08/08

Vulnerability Publication Date: 2012/04/27

Reference Information

CVE: CVE-2012-6593, CVE-2012-6602

BID: 62124, 62126