Palo Alto Networks PAN-OS 3.1.10 / 4.x < 4.0.5 Multiple Command Injections

Critical Nessus Plugin ID 72818

Synopsis

The remote host is affected by multiple command injection vulnerabilities.

Description

The remote host is running a version of Palo Alto Networks PAN-OS prior to 3.1.10 / 4.0.5. It is, therefore, affected by multiple command injection vulnerabilities :

- A vulnerability exists that allows an authenticated user to inject arbitrary shell commands via the CLI.
(CVE-2012-6591 / PAN-SA-2012-0002)

- A vulnerability exists that allows an unauthenticated user to inject commands as root on the device.
(CVE-2012-6592 / PAN-SA-2012-0003)

Solution

Upgrade to PAN-OS version 3.1.10 / 4.0.5 or later.

See Also

https://securityadvisories.paloaltonetworks.com/Home/Detail/2

https://securityadvisories.paloaltonetworks.com/Home/Detail/3

Plugin Details

Severity: Critical

ID: 72818

File Name: palo_alto_PAN-SA-2012-0002_0003.nasl

Version: $Revision: 1.5 $

Type: combined

Published: 2014/03/05

Modified: 2016/05/16

Dependencies: 72816

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/08/08

Vulnerability Publication Date: 2012/04/27

Reference Information

CVE: CVE-2012-6591, CVE-2012-6592

BID: 62123, 62125