Lexmark Printer Configuration Persistent XSS

Medium Nessus Plugin ID 72772


The remote printer is potentially affected by a cross-site scripting vulnerability.


The version of the remote Lexmark printer is potentially affected by a cross-site scripting vulnerability. An input validation error exists related to the 'General Settings' configuration page and the 'Location' and 'Contact Name' parameters that could allow persistent cross-site scripting attacks.


Upgrade to the vendor's suggested Lexmark printer firmware version or later.

See Also


Plugin Details

Severity: Medium

ID: 72772

File Name: lexmark_printer_TE585.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2014/03/03

Modified: 2015/02/03

Dependencies: 46311

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/h:lexmark:c52x, cpe:/h:lexmark:c53x, cpe:/h:lexmark:c920, cpe:/h:lexmark:c935dn, cpe:/h:lexmark:e250, cpe:/h:lexmark:e350, cpe:/h:lexmark:e450, cpe:/h:lexmark:t64x, cpe:/h:lexmark:w840

Required KB Items: www/lexmark_printer/model, www/lexmark_printer/base_ver

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/31

Vulnerability Publication Date: 2014/01/31

Reference Information

CVE: CVE-2013-6033

BID: 65277

OSVDB: 102752

CERT: 108062

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990