ImageMagick < 6.8.8-5 Multiple PSD Handling Buffer Overflows

Medium Nessus Plugin ID 72722


The remote Windows host contains an application that is affected by a multiple buffer overflow vulnerabilities.


The remote Windows host is running a version of ImageMagick prior to version 6.8.8-5. It is, therefore, affected by the following vulnerabilities :

- A buffer overflow error exists related to PSD image file handling and the 'DecodePSDPixels' function.

- A buffer overflow error exists related to PDF image file handling and RLE decoding. (CVE-2014-2030)

Exploitation of these issues could result in a denial of service or arbitrary code execution.


Upgrade to ImageMagick 6.8.8-5 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: Medium

ID: 72722

File Name: imagemagick_6_8_8_5.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2014/02/27

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/02/03

Vulnerability Publication Date: 2014/02/08

Reference Information

CVE: CVE-2014-1958, CVE-2014-2030

BID: 65478, 65563

OSVDB: 103206, 103225

EDB-ID: 31688