ImageMagick < 6.8.7-6 WritePSDImage PSD Handling Memory Corruption

Medium Nessus Plugin ID 72721


The remote Windows host contains an application that is affected by a memory corruption vulnerability.


The remote Windows host is running a version of ImageMagick prior to version 6.8.7-6. It is, therefore, affected by a memory corruption vulnerability related to PSD image file handling and the 'WritePSDImage' function. Exploitation of this issue could result in a denial of service or arbitrary code execution.


Upgrade to ImageMagick 6.8.7-6 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: Medium

ID: 72721

File Name: imagemagick_6_8_7_6.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2014/02/27

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/11/16

Vulnerability Publication Date: 2013/11/14

Reference Information

CVE: CVE-2014-1947

BID: 65683

OSVDB: 103206