Apache Tomcat 7.0.x < 7.0.50 Multiple Vulnerabilities

Medium Nessus Plugin ID 72691


The remote Apache Tomcat server is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat 7.0.x listening on the remote host is prior to 7.0.50. It is, therefore, affected by the following vulnerabilities :

- The fix for CVE-2012-3544 was not complete and limits are not properly applied to chunk extensions and whitespaces in certain trailing headers. This error could allow denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE) processing that could disclose sensitive information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Apache Tomcat version 7.0.50 or later.

See Also


Plugin Details

Severity: Medium

ID: 72691

File Name: tomcat_7_0_50.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Web Servers

Published: 2014/02/25

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/02/25

Vulnerability Publication Date: 2014/01/08

Reference Information

CVE: CVE-2013-4322, CVE-2013-4590

BID: 65767, 65768

OSVDB: 103706, 103707