Apache Tomcat 6.0.x < 6.0.39 Multiple Vulnerabilities

Medium Nessus Plugin ID 72690

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 6.0.x listening on the remote host is prior to 6.0.39. It is, therefore, affected by the following vulnerabilities :

- The version of Java used to build the application generates Javadoc containing a frame injection error.
(CVE-2013-1571)

- The fix for CVE-2005-2090 was not complete and the application does not reject requests with multiple Content-Length HTTP headers or with Content-Length HTTP headers when using chunked encoding.
(CVE-2013-4286)

- The fix for CVE-2012-3544 was not complete and limits are not properly applied to chunk extensions and whitespaces in certain trailing headers. This error allows denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE) processing that discloses sensitive information.
(CVE-2013-4590)

- An error exists related to the 'disableURLRewriting' configuration option and session IDs. (CVE-2014-0033)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 6.0.39 or later.

See Also

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.39

Plugin Details

Severity: Medium

ID: 72690

File Name: tomcat_6_0_39.nasl

Version: 1.14

Type: remote

Family: Web Servers

Published: 2014/02/25

Updated: 2018/09/17

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-4286

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/31

Vulnerability Publication Date: 2013/06/18

Reference Information

CVE: CVE-2013-1571, CVE-2013-4286, CVE-2013-4322, CVE-2013-4590, CVE-2014-0033

BID: 60634, 65767, 65768, 65769, 65773