Core FTP Server < 1.2 Build 508 lstrcpy Overflow Code Execution

high Nessus Plugin ID 72661
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The FTP server running on the remote host is affected by a code execution vulnerability.

Description

The version of Core FTP running on the remote host is prior to 1.2 build 508. It is, therefore, affected by buffer overflow conditions in the RegQueryValueExA() and lstrcpy() functions due to improper validation of user-supplied input when reading data from the config.dat file and/or from the Windows Registry. A local attacker can exploit this to cause a denial of service condition or to execute arbitrary code.

Solution

Upgrade to Core FTP version 1.2 build 508 or later.

See Also

http://www.nessus.org/u?12696fbd

https://seclists.org/fulldisclosure/2014/Feb/172

Plugin Details

Severity: High

ID: 72661

File Name: coreftp_server_1_2_508.nasl

Version: 1.6

Type: remote

Family: FTP

Published: 2/24/2014

Updated: 11/27/2019

Dependencies: coreftp_server_detect.nbin

Risk Information

CVSS Score Source: CVE-2014-1215

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:coreftp:coreftp

Required KB Items: installed_sw/Core FTP Server

Exploit Ease: No known exploits are available

Patch Publication Date: 1/9/2014

Vulnerability Publication Date: 1/18/2014

Reference Information

CVE: CVE-2014-1215

BID: 65692