GLSA-201402-18 : GNU Midnight Commander: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 72613


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201402-18 (GNU Midnight Commander: User-assisted execution of arbitrary code)

GNU Midnight Commander does not properly sanitize environment variables.
Impact :

A remote attacker could entice a user to open a specially crafted archive file using GNU Midnight Commander, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All GNU Midnight Commander users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-misc/mc-4.8.7'

See Also

Plugin Details

Severity: Medium

ID: 72613

File Name: gentoo_GLSA-201402-18.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2014/02/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/02/20

Reference Information

CVE: CVE-2012-4463

BID: 55777

OSVDB: 86192

GLSA: 201402-18