Mandriva Linux Security Advisory : puppet (MDVSA-2014:040)

Low Nessus Plugin ID 72564


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been discovered and corrected in puppet :

Puppet before 3.3.3 and 3.4 before 3.4.1 and Puppet Enterprise (PE) before 2.8.4 and 3.1 before 3.1.1 allows local users to overwrite arbitrary files via a symlink attack on unspecified files (CVE-2013-4969).

The updated packages have been upgraded to the 2.7.25 version which is not vulnerable to this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Low

ID: 72564

File Name: mandriva_MDVSA-2014-040.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2014/02/19

Modified: 2014/02/19

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Temporal Score: 1.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:emacs-puppet, p-cpe:/a:mandriva:linux:puppet, p-cpe:/a:mandriva:linux:puppet-server, p-cpe:/a:mandriva:linux:vim-puppet, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/02/18

Reference Information

CVE: CVE-2013-4969

BID: 64552

MDVSA: 2014:040