Mandriva Linux Security Advisory : libgadu (MDVSA-2014:039)

High Nessus Plugin ID 72563


The remote Mandriva Linux host is missing one or more security updates.


Updated libgadu packages fix security vulnerability :

A malicious server or man-in-the-middle could send a large value for Content-Length and cause an integer overflow which could lead to a buffer overflow in Gadu-Gadu HTTP parsing (CVE-2013-6487).


Update the affected lib64gadu-devel and / or lib64gadu3 packages.

See Also

Plugin Details

Severity: High

ID: 72563

File Name: mandriva_MDVSA-2014-039.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/02/19

Modified: 2014/02/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64gadu-devel, p-cpe:/a:mandriva:linux:lib64gadu3, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/02/18

Reference Information

CVE: CVE-2013-6487

BID: 65188

MDVSA: 2014:039