3S CoDeSys Runtime Toolkit NULL Pointer Dereference (uncredentialed check)

Medium Nessus Plugin ID 72558


An application on the remote host is affected by a NULL pointer dereference vulnerability.


The remote host has a version of the CoDeSys PLCWinNT listening that is affected by an unspecified NULL pointer dereference vulnerability. Successful exploitation will trigger a program crash resulting in a denial of service condition.


Upgrade to CoDeSys PLCWinNT or later.

Plugin Details

Severity: Medium

ID: 72558

File Name: scada_codesys_plcwinnt_2_4_7_44_remote.nbin

Version: $Revision: 1.21 $

Type: remote

Family: SCADA

Published: 2014/02/18

Modified: 2018/01/29

Dependencies: 62795

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:3s-software:codesys_runtime_toolkit

Required KB Items: SCADA/CoDeSys

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/19

Vulnerability Publication Date: 2014/01/30

Reference Information

CVE: CVE-2014-0757

BID: 65259

OSVDB: 102712

ICSA: 14-030-01