Shockwave Player <= 12.0.7.148 Multiple Memory Corruption Vulnerabilities (APSB14-06)

Critical Nessus Plugin ID 72435

Synopsis

The remote Windows host contains a web browser plugin that is affected by multiple memory corruption vulnerabilities.

Description

The remote Windows host contains a version of Adobe's Shockwave Player that is prior to or equal to 12.0.7.148. It is, therefore, potentially affected by two unspecified memory corruption vulnerabilities. A remote attacker could exploit these issues by tricking a user into viewing a malicious Shockwave file, resulting in arbitrary code execution.

Solution

Upgrade to Adobe Shockwave Player 12.0.9.149 or later.

See Also

https://helpx.adobe.com/security/products/shockwave/apsb14-06.html

Plugin Details

Severity: Critical

ID: 72435

File Name: shockwave_player_apsb14-06.nasl

Version: 1.7

Type: local

Agent: windows

Family: Windows

Published: 2014/02/12

Updated: 2019/11/26

Dependencies: 39564

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2014-0501

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:shockwave_player

Required KB Items: SMB/shockwave_player

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/02/11

Vulnerability Publication Date: 2014/02/11

Reference Information

CVE: CVE-2014-0500, CVE-2014-0501

BID: 65490, 65493