IrfanView < 4.37 Multiple Buffer Overflow Vulnerabilities

High Nessus Plugin ID 72395


A graphic viewer installed on the remote host is affected by multiple buffer overflow vulnerabilities.


The remote Windows host contains a version of IrfanView prior to version 4.37. It is, therefore, reportedly affected by multiple buffer overflow vulnerabilities :

- A boundary error exists when handling the LZW code stream within GIF files that could lead to arbitrary code execution. (CVE-2013-5351)

- An error exists in the Thumbnail 'tooltips' feature when viewing a specially crafted file contained in a folder named using multi-byte characters in the Thumbnails window, such as when handling Japanese folder names.
Exploitation of this issue could result in arbitrary code execution. (CVE-2013-6932)


Upgrade to IrfanView version 4.37 or later.

See Also

Plugin Details

Severity: High

ID: 72395

File Name: irfanview_437.nasl

Version: $Revision: 1.1 $

Type: local

Agent: windows

Family: Windows

Published: 2014/02/07

Modified: 2014/02/08

Dependencies: 57559

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:irfanview:irfanview

Required KB Items: SMB/IrfanView/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/16

Vulnerability Publication Date: 2013/12/17

Reference Information

CVE: CVE-2013-5351, CVE-2013-6932

BID: 64388, 64561

OSVDB: 101064, 101065