Dell KACE K1000 < 5.5 Multiple SQL Injection Vulnerabilities

Medium Nessus Plugin ID 72392

Synopsis

The web interface for a system management appliance is affected by multiple SQL injection vulnerabilities.

Description

The web interface for the version of the Dell KACE K1000 appliance on the remote host is affected by multiple SQL injection vulnerabilities. The following parameters and scripts are affected :

- The 'TYPE_ID' parameter of 'adminui/history_log.php'.

- The 'ID' parameter of 'adminui/service.php', 'adminui/software.php', 'adminui/settings_network_scan.php', 'adminui/asset.php', 'adminui/asset_type.php', 'adminui/metering.php', 'adminui/mi.php', 'adminui/replshare.php', 'adminui/kbot.php', '/userui/advisory_detail.php', and '/userui/ticket.php'.

- The 'macAddress' and 'getKBot' parameters of '/service/kbot_service.php'.

- The 'ORDER[]' parameter of '/userui/ticket_list.php'.

Note that Nessus has not tested for these issues, but instead has relied only on the application's self-reported version number.

Solution

Upgrade KACE to version 5.5 or later

See Also

https://www.vulnerability-lab.com/get_content.php?id=832

http://www.nessus.org/u?e29997ea

http://www.kace.com/support/resources/kb/solutiondetail?sol=SOL119257

Plugin Details

Severity: Medium

ID: 72392

File Name: dell_kace_k1000_5_5_mult_sqli.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2014/02/07

Updated: 2019/11/26

Dependencies: 72391

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-1671

CVSS v2.0

Base Score: 6.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/h:dell:kace_k1000_systems_management_appliance

Required KB Items: www/dell_kace_k1000

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/08/10

Vulnerability Publication Date: 2013/07/22

Reference Information

CVE: CVE-2014-1671

BID: 61382, 65029

EDB-ID: 27039