WinSCP < 5.1.6 RSA Signature Blob Integer Overflow

Medium Nessus Plugin ID 72388


The remote Windows host has an application installed that is affected by an integer overflow.


The WinSCP program installed on the remote host is a version prior to 5.1.6. It therefore contains code from PuTTY that is affected by an integer overflow related to handling RSA signature data. This error allows a remote attacker to crash the application.


Upgrade to WinSCP version 5.1.6 / 5.2.2 beta or later.

See Also

Plugin Details

Severity: Medium

ID: 72388

File Name: winscp_5_1_6.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2014/02/07

Modified: 2016/05/20

Dependencies: 72387

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:winscp:winscp

Required KB Items: installed_sw/WinSCP

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/07/29

Vulnerability Publication Date: 2013/07/21

Reference Information

CVE: CVE-2013-4852

BID: 61599

OSVDB: 95970