Amazon Linux AMI : varnish (ALAS-2014-276)

Medium Nessus Plugin ID 72294

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Varnish before 3.0.5 allows remote attackers to cause a denial of service (child-process crash and temporary caching outage) via a GET request with trailing whitespace characters and no URI.

varnish 3.0.3 uses world-readable permissions for the /var/log/varnish/ directory and the log files in the directory, which allows local users to obtain sensitive information by reading the files. NOTE: some of these details are obtained from third party information.

Solution

Run 'yum update varnish' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2014-276.html

Plugin Details

Severity: Medium

ID: 72294

File Name: ala_ALAS-2014-276.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/02/05

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:varnish, p-cpe:/a:amazon:linux:varnish-debuginfo, p-cpe:/a:amazon:linux:varnish-docs, p-cpe:/a:amazon:linux:varnish-libs, p-cpe:/a:amazon:linux:varnish-libs-devel, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2014/01/14

Reference Information

CVE: CVE-2013-0345, CVE-2013-4484

ALAS: 2014-276