GLSA-201401-32 : Exim: Multiple vulnerabilities

High Nessus Plugin ID 72159


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201401-32 (Exim: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Exim. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could possibly execute arbitrary code with root privileges, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Exim users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=mail-mta/exim-4.80.1'

See Also

Plugin Details

Severity: High

ID: 72159

File Name: gentoo_GLSA-201401-32.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2014/01/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:exim, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/27

Exploitable With


Core Impact

Metasploit (Exim4 string_format Function Heap Buffer Overflow)

Reference Information

CVE: CVE-2010-2023, CVE-2010-2024, CVE-2010-4344, CVE-2010-4345, CVE-2011-0017, CVE-2011-1407, CVE-2011-1764, CVE-2012-5671

BID: 40451, 40454, 45308, 45341, 46065, 47736, 47836, 56285

OSVDB: 65158, 65159, 69685, 69860, 70696, 72156, 72642, 86616

GLSA: 201401-32