Puppet Symlink File Overwrite

Low Nessus Plugin ID 72151

Synopsis

A web application on the remote host is potentially affected by a file overwrite vulnerability.

Description

According to its self-reported version number, the Puppet install on the remote host is potentially affected by an error related to temporary files and their use. A local attacker could potentially use a symlink attack to overwrite arbitrary files.

Solution

Upgrade to Puppet 3.3.3 / 3.4.1 or Puppet Enterprise 2.8.4 / 3.1.1 or later.

See Also

https://puppet.com/security/cve/cve-2013-4969

Plugin Details

Severity: Low

ID: 72151

File Name: puppet_cve_2013-4969.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2014/01/27

Updated: 2018/11/15

Dependencies: 66233

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.1

Temporal Score: 1.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/12/26

Vulnerability Publication Date: 2013/12/26

Reference Information

CVE: CVE-2013-4969

BID: 64552