Drupal 6.x < 6.30 OpenID Module Account Hijacking

Medium Nessus Plugin ID 72102


The remote web server is running a PHP application that is affected by a security bypass vulnerability.


The remote web server is running a version of Drupal that is 6.x prior to 6.30. It is, therefore, affected by a security bypass vulnerability in the OpenID module that could allow an authenticated attacker to hijack other users' accounts. Only user accounts associated with one or more OpenID entities are affected.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to version 6.30 or later.

See Also



Plugin Details

Severity: Medium

ID: 72102

File Name: drupal_6_30.nasl

Version: $Revision: 1.8 $

Type: remote

Family: CGI abuses

Published: 2014/01/23

Modified: 2017/05/16

Dependencies: 18638

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/15

Vulnerability Publication Date: 2014/01/15

Reference Information

CVE: CVE-2014-1475

BID: 64973

OSVDB: 102124