GLSA-201401-25 : ldns: Arbitrary code execution

Medium Nessus Plugin ID 72080


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201401-25 (ldns: Arbitrary code execution)

ldns contains a heap-based buffer overflow in the ldns_rr_new_frm_str_internal function.
Impact :

A remote attacker could execute arbitrary code or cause a Denial of Service condition with a crafted Resource Record.
Workaround :

There is no known workaround at this time.


All ldns users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/ldns-1.6.11' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying these packages.
NOTE: This is a legacy GLSA. Updates for all affected architectures are available since October 11, 2011. It is likely that your system is already no longer affected by this issue.

See Also

Plugin Details

Severity: Medium

ID: 72080

File Name: gentoo_GLSA-201401-25.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2014/01/22

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ldns, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/21

Reference Information

CVE: CVE-2011-3581

BID: 49748

GLSA: 201401-25