GLSA-201401-10 : libexif, exif: Multiple vulnerabilities

High Nessus Plugin ID 72032


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201401-10 (libexif, exif: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in libexif and exif.
Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user to open a specially crafted image file using exif or an application linked against libexif, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All libexif users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libexif-0.6.21' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.
All exif users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/exif-0.6.21'

See Also

Plugin Details

Severity: High

ID: 72032

File Name: gentoo_GLSA-201401-10.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2014/01/20

Modified: 2016/05/12

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:exif, p-cpe:/a:gentoo:linux:libexif, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/19

Reference Information

CVE: CVE-2012-2812, CVE-2012-2813, CVE-2012-2814, CVE-2012-2836, CVE-2012-2837, CVE-2012-2840, CVE-2012-2841, CVE-2012-2845

BID: 54437

OSVDB: 83753, 83754, 83755, 83756, 83757, 83758, 83759

GLSA: 201401-10