Adobe AIR for Mac <= Multiple Vulnerabilities (APSB14-02)

High Nessus Plugin ID 71952


The remote Mac OS X host contains a version of Adobe AIR that is affected by multiple vulnerabilities.


According to its version, the instance of Adobe AIR on the remote Mac OS X host is or earlier. It is, therefore, reportedly affected by the following vulnerabilities :

- An unspecified vulnerability exists that can be used to bypass Flash Player security protections.

- An unspecified vulnerability exists that can be used to bypass memory address layout randomization.


Upgrade to Adobe AIR or later.

See Also

Plugin Details

Severity: High

ID: 71952

File Name: macosx_adobe_air_4_0_0_1390.nasl

Version: $Revision: 1.7 $

Type: local

Agent: macosx

Published: 2014/01/14

Modified: 2017/05/16

Dependencies: 56960

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: MacOSX/Adobe_AIR/Version

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2014/01/14

Vulnerability Publication Date: 2014/01/14

Reference Information

CVE: CVE-2014-0491, CVE-2014-0492

BID: 64807, 64810

OSVDB: 101982, 101983