GLSA-201401-01 : Libgdiplus: Arbitrary code execution

Medium Nessus Plugin ID 71801


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201401-01 (Libgdiplus: Arbitrary code execution)

An integer overflow flaw has been discovered in Libgdiplus.
Impact :

A remote attacker could entice a user to open a specially crafted TIFF/JPEG/BMP file, potentially resulting in arbitrary code execution.
Workaround :

There is no known workaround at this time.


All Libgdiplus users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-dotnet/libgdiplus-2.6.7-r1' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.
NOTE: This is a legacy GLSA. Updates for all affected architectures are available since September 12, 2010. It is likely that your system is already no longer affected by this issue.

See Also

Plugin Details

Severity: Medium

ID: 71801

File Name: gentoo_GLSA-201401-01.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2014/01/06

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libgdiplus, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/05

Reference Information

CVE: CVE-2010-1526

BID: 42602

OSVDB: 67373, 67374, 67375

GLSA: 201401-01