Winamp < 5.666 Multiple Memory Corruptions

Medium Nessus Plugin ID 71787


The remote Windows host contains a multimedia application that is affected by multiple memory corruption vulnerabilities.


The remote host is running Winamp, a media player for Windows. The version of Winamp installed on the remote host is a version prior to 5.666. It is, therefore, reportedly affected by the following vulnerabilities :

- A memory corruption error exists in 'in_midi.dll' when processing specially crafted '.kar' files.

- A memory corruption error exists in 'libmp4v2.dll' due to a NULL pointer dereference when processing specially crafted files.

An attacker could exploit these vulnerabilities to cause a denial of service.


Upgrade to Winamp 5.666 ( or later.

See Also

Plugin Details

Severity: Medium

ID: 71787

File Name: winamp_5666.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2014/01/03

Modified: 2014/08/20

Dependencies: 15817

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/12/12

Vulnerability Publication Date: 2013/10/27

Reference Information

BID: 63914