Apache Subversion 1.4.x - 1.7.12 / 1.8.x < 1.8.3 Multiple Symlink File Overwrite Vulnerabilities

Low Nessus Plugin ID 71568


The remote host has an application that is affected by multiple symlink overwrite vulnerabilities.


The version of Subversion Server installed on the remote host is prior to version 1.8.3. It is, therefore, affected by multiple symlink file overwrite vulnerabilities :

- An error exists in the function 'handle_options' in the file 'svnwcsub.py' that could allow a local attacker to use a symlink attack to overwrite arbitrary files. Note that this issue only affects the 1.8.x branch.

- An error exists in the function 'write_pid_file' that could allow a local attacker to use a symlink attack to overwrite arbitrary files. (CVE-2013-4277)


Upgrade to Subversion Server 1.7.13 / 1.8.3 or later or apply the vendor patches or workarounds.

See Also



Plugin Details

Severity: Low

ID: 71568

File Name: subversion_1_8_3.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2013/12/20

Modified: 2016/05/13

Dependencies: 40619

Risk Information

Risk Factor: Low


Base Score: 3.2

Temporal Score: 2.8

Vector: CVSS2#AV:L/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Required KB Items: installed_sw/Subversion Server, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/08/30

Vulnerability Publication Date: 2013/08/30

Reference Information

CVE: CVE-2013-4262, CVE-2013-4277

BID: 62266, 68965

OSVDB: 96930, 96931, 96932