Apache Subversion 1.8.x < 1.8.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 71567


The remote host has an application that is affected by multiple vulnerabilities.


The version of Subversion Server installed on the remote host is prior to version 1.8.2. It is, therefore, affected by multiple vulnerabilities :

- A repository corruption vulnerability related to 'FileSystem atop the FileSystem' (FSFS) repositories and handling packed revision properties editing.

- A symlink privilege escalation vulnerability in 'svnwcsub.py' and 'irkerbridge.py' exists when the
--pidfile option is used. The option creates temporary files insecurely, and may allow a local attacker to use a symlink attack against a pid file to gain elevated privileges. (CVE-2013-7393)


Upgrade to Subversion Server 1.8.3 or later, or apply the vendor patch or workaround.

Note that version 1.8.2 was not publicly released, and thus version 1.8.3 is the recommended version.

See Also




Plugin Details

Severity: Medium

ID: 71567

File Name: subversion_1_8_2.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2013/12/20

Modified: 2017/11/21

Dependencies: 40619

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Required KB Items: installed_sw/Subversion Server, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/08/21

Vulnerability Publication Date: 2013/08/30

Reference Information

CVE: CVE-2013-4246, CVE-2013-7393

BID: 62266, 68966

OSVDB: 96929, 109720