GLSA-201312-14 : libsndfile: Arbitrary code execution

Medium Nessus Plugin ID 71507


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201312-14 (libsndfile: Arbitrary code execution)

An integer overflow flaw has been discovered in Libsndfile.
Impact :

A remote attacker could entice a user to open a specially crafted PAF file using libsndfile, possibly resulting in execution of arbitrary code with the privileges of the process, or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All libsndfile users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libsndfile-1.0.25' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.
NOTE: This is a legacy GLSA. Updates for all affected architectures are available since September 12, 2011. It is likely that your system is already no longer affected by this issue.

See Also

Plugin Details

Severity: Medium

ID: 71507

File Name: gentoo_GLSA-201312-14.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2013/12/18

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libsndfile, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/17

Reference Information

CVE: CVE-2011-2696

BID: 48644

OSVDB: 74055

GLSA: 201312-14