Debian DSA-2820-1 : nspr - integer overflow

High Nessus Plugin ID 71502

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that NSPR, Netscape Portable Runtime library, could crash an application using the library when parsing a certificate that causes an integer overflow. This flaw only affects 64-bit systems.

Solution

Upgrade the nspr packages.

For the oldstable distribution (squeeze), this problem has been fixed in version 4.8.6-1+squeeze1.

For the stable distribution (wheezy), this problem has been fixed in version 2:4.9.2-1+deb7u1.

See Also

https://packages.debian.org/source/squeeze/nspr

https://packages.debian.org/source/wheezy/nspr

https://www.debian.org/security/2013/dsa-2820

Plugin Details

Severity: High

ID: 71502

File Name: debian_DSA-2820.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2013/12/18

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nspr, cpe:/o:debian:debian_linux:6.0, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/17

Reference Information

CVE: CVE-2013-5607

BID: 63802

DSA: 2820