Mac OS X : Cisco AnyConnect Secure Mobility Client 2.x / 3.x < 3.0(629) Multiple Vulnerabilities

High Nessus Plugin ID 71465


The remote host has software installed that is affected by multiple vulnerabilities.


The remote host has a version of Cisco AnyConnect 2.x or 3.x prior to 3.0(629) and is, therefore, affected by the following vulnerabilities :

- When the client is obtained from the VPN headend using a web browser, a helper application performs the download and installation. This helper application does not verify the authenticity of the downloaded installer, which could allow an attacker to send malicious code to the user instead. Note 2.x versions prior to 2.5.3041 are affected by this vulnerability. (CVE-2011-2040)

- When the VPNAPI COM module calls the ATL framework, certain input data are not properly validated. This could allow a buffer overflow, which could lead to arbitrary code execution. (CVE-2013-5559)


Upgrade to Cisco AnyConnect Secure Mobility Client 3.0(629) or later.

See Also

Plugin Details

Severity: High

ID: 71465

File Name: macosx_cisco_anyconnect_3_0_629.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2013/12/16

Modified: 2017/05/16

Dependencies: 59822

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:anyconnect_secure_mobility_client

Required KB Items: MacOSX/Cisco_AnyConnect/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/11/04

Vulnerability Publication Date: 2011/06/01

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2011-2040, CVE-2013-5559

BID: 48081, 63491

OSVDB: 72715, 99258

CISCO-BUG-ID: CSCsy05934, CSCuj58139

CISCO-SA: cisco-sa-20110601-ac

CERT: 490097