PHP 5.4.x < 5.4.23 OpenSSL openssl_x509_parse() Memory Corruption

high Nessus Plugin ID 71427
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is potentially affected by a memory corruption vulnerability.


According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.23. It is, therefore, potentially affected by a memory corruption flaw in the way the openssl_x509_parse() function of the PHP OpenSSL extension parsed X.509 certificates. A remote attacker could use this flaw to provide a malicious, self-signed certificate or a certificate signed by a trusted authority to a PHP application using the aforementioned function. This could cause the application to crash or possibly allow the attacker to execute arbitrary code with the privileges of the user running the PHP interpreter.

Note that this plugin does not attempt to exploit the vulnerability, but instead relies only on PHP's self-reported version number.


Upgrade to PHP version 5.4.23 or later.

See Also

Plugin Details

Severity: High

ID: 71427

File Name: php_5_4_23.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 12/14/2013

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2013-6420


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 12/12/2013

Vulnerability Publication Date: 12/2/2013

Reference Information

CVE: CVE-2013-6420

BID: 64225

EDB-ID: 30395