Debian DSA-2810-1 : ruby1.9.1 - heap overflow

Medium Nessus Plugin ID 71221

Synopsis

The remote Debian host is missing a security-related update.

Description

Charlie Somerville discovered that Ruby incorrectly handled floating point number conversion. If an application using Ruby accepted untrusted input strings and converted them to floating point numbers, an attacker able to provide such input could cause the application to crash or, possibly, execute arbitrary code with the privileges of the application.

Solution

Upgrade the ruby1.9.1 packages.

For the oldstable distribution (squeeze), this problem has been fixed in version 1.9.2.0-2+deb6u2.

For the stable distribution (wheezy), this problem has been fixed in version 1.9.3.194-8.1+deb7u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=730178

https://packages.debian.org/source/wheezy/ruby1.9.1

https://www.debian.org/security/2013/dsa-2810

Plugin Details

Severity: Medium

ID: 71221

File Name: debian_DSA-2810.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2013/12/05

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby1.9.1, cpe:/o:debian:debian_linux:6.0, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/12/04

Reference Information

CVE: CVE-2013-4164

BID: 63873

DSA: 2810