nginx < 1.4.4 / 1.5.7 ngx_parse_http Security Bypass

High Nessus Plugin ID 71117


The remote web server is affected by a security bypass vulnerability.


According to the self-reported version in the Server response header, the installed version of nginx is greater than 0.8.41 but prior to 1.4.4 / 1.5.7. It is, therefore, affected by a security bypass vulnerability in 'ngx_http_parse.c' when a file with a space at the end of the URI is requested.


Either apply the patch manually or upgrade to nginx 1.4.4 / 1.5.7 or later.

See Also

Plugin Details

Severity: High

ID: 71117

File Name: nginx_1_5_7.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Web Servers

Published: 2013/11/27

Modified: 2018/01/26

Dependencies: 106375

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/11/19

Vulnerability Publication Date: 2013/11/19

Reference Information

CVE: CVE-2013-4547

BID: 63814

OSVDB: 100015