Mandriva Linux Security Advisory : ruby (MDVSA-2013:286)

Medium Nessus Plugin ID 71100


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability was found and corrected in ruby :

Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse (CVE-2013-4164).

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 71100

File Name: mandriva_MDVSA-2013-286.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/11/27

Modified: 2015/01/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ruby, p-cpe:/a:mandriva:linux:ruby-devel, p-cpe:/a:mandriva:linux:ruby-doc, p-cpe:/a:mandriva:linux:ruby-tk, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/11/26

Reference Information

CVE: CVE-2013-4164

BID: 63873

MDVSA: 2013:286